Funciones de Excel

Todas las Funciones de Excel, ejemplos, tipos de funciones.

Funciones de Excel
Logo Excel Avanzado

Sumar si texto contiene asterisco

| Sin comentarios

En este caso lo que vamos a realizar es sumar los elementos de una columna, en base a textos en otra columna que contienen un asterisco.

Sumar si texto contiene asterisco

En base a los datos mostrado, se necesita que los datos correspondientes a los montos de las filas 4, 5 y 7 se sumen debido a que en el texto de la columna C existe un asterisco. 

Fórmula para sumar si texto contiene asterisco 

Tomando en cuenta los conceptos relacionados al uso del asterisco, examinados en: Comodines en Excel

Se ha elaborado la siguiente fórmula: 

=SUMAR.SI(C3:C10,"*~**",D3:D10)

En esta fórmula, la parte central esta la condición del Sumar.si, en donde encontramos la condición que aplica a los datos de la columna C: 

*~**

El primer asterisco representa que podemos encontrar cualquier texto, el segundo y tercer carácter  operan de forma combinada, y sirve para indicar que debe aparecer el carácter asterisco como parte del texto, y el cuarto carácter (un asterisco) nos indica que el texto puede finalizar con cualquier texto.

En resumen esta condición permite sumar si el texto contiene asterisco en cualquier parte del texto.

Otros ejemplos para sumar si texto contiene asterisco 

En base a la condiciones mostrada podemos usar otras condiciones como por ejemplo: 

*~* En este caso se trata de sumar si el texto contiene un asterisco al finalizar el Texto.

~** En este ejemplo se sumará solo los caso en los que el primer carácter del texto es un asterisco

~* Usando esta condición se busca sumar solo si el texto contiene solo un asterisco (no contiene ningún otro carácter) 

 

Deja una respuesta

Los campos requeridos estan marcados con *.